Tuesday, February 8, 2011

I Know, I Know...

It's been a really long time since I posted last. I've been slacking, I know, but I did go on vacation, there was our 3rd worst blizzard ever in history and it's been really boring over here. I haven't seen much of anything, and if I do fire off a few shots of this or that, the images are not blog-worthy, so... I've saved you some time. You're welcome!

Anyhoo, I did find something pretty interesting...



Yep, a nice sized buck! Check out his mass! I was very impressed. (My brain is speaking to me...) "Oh, wait a minute! He only has one antler. Cool! My first shed sighting! It looks kinda freshly dropped...I wonder if I can find it?"



I had a dentist appointment to go to, so I left him for awhile. When I came back, he was gone (which is good because I have an agenda!). I went trudging thru the 2-3 foot deep snow and came back with wet jeans, a runny nose and no antler. Bummer!

5 comments:

Montanagirl said...

They're in the process of shedding here as well. Nice photos! And welcome back. I miss your posts and wonderful photography.

Chris said...

Excellent shots. We missed you a lot, it is nice to see you back!

Ruth's Photo Blog said...

He is really quite impressive.

Daniel said...

A temporary absence was well rewarded.

Daniel

Explore. Dream. Discover.
http://daniels-view.blogspot.com/

--

Willard said...

Glad you got to see him with one gone and one still there. Most of the bucks in our area have shed by now, but I have found no antlers. One of them(a three point),came in one day with one still intact, and he lost the other within a day or so.